IntelliJ Idea控制台报错:类文件具有错误的版本55.0, 应为 52.0

hutuyun-ad-banner.png ai-qy.gif

Java多模块项目,某个模块依赖的JDK版本可能会不同。这里我的工作流Activiti7最新版需要JDK11进行编译,运行时报错:

类文件具有错误的版本55.0, 应为 52.0

解决办法:在设置里将对应模块的JDK依赖改为JDK11,具体路径File -> Project Structure -> Modules -> Dependencies

2023-01-29_113358.jpg

附各个版本JDK使用的类文件格式版本号:

Major Minor  JDK
  45    3    1(.0.2)
  45    3    1.1
  46    0    1.2
  47    0    1.3
  48    0    1.4
  49    0    5
  50    0    6
  51    0    7
  52    0    8
  53    0    9  
  54    0    10  
  55    0    11  
  56    0    12

参考:

  1. IDEA运行时报错“类文件具有错误的版本 55.0, 应为 52.0”的解决方法
赞(2)
未经允许禁止转载:优米格 » IntelliJ Idea控制台报错:类文件具有错误的版本55.0, 应为 52.0

评论 抢沙发

合作&反馈&投稿

商务合作、问题反馈、投稿,欢迎联系

广告合作侵权联系